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The Instant Web Page
Any designer who has created graphics for the web using Photoshop knows how tedious it can be to move
ideas from a single Photoshop file to a collection of web-friendly GIF or JPG files. And all web programmers
know how difficult it can be to get those graphics to appear in the correct positions on the resulting web page.

With PhotoWebber it is no longer necessary to chop Photoshop files into little pieces and reassemble them
manually in an HTML editor. PhotoWebber translates layered Photoshop files directly into matching HTML
layouts effortlessly.

In this tutorial you will import a Photoshop file and build an interactive web page in just two steps.

1. Start PhotoWebber and Import
your Photoshop file.

From the File menu, select Import
Graphics.

Choose the Photoshop file named
TUTORIAL1.PSD in the
PhotoWebberSampleFiles folder, and
click Open.

 

Tip: PhotoWebber takes advantage of the information in
your Photoshop file to automatically set up your web page:

Auto Button Creation allows PhotoWebber to use
Photoshop layer names to automatically generate
JavaScript buttons and menus.

●   

Solid color Photoshop background layers are
converted to the page background color.

●   

Solid color rectangular layers are converted to Color
Areas (table or layer background colors).

●   



2. Build your page and view the
results in your web browser:

From the Output menu, select Build
All.

PhotoWebber will prompt you to
select a Site Folder. The Site Folder is
the folder in which PhotoWebber will
build the HTML and graphics files for
the web page.

Select Set from the Build Where
window and choose a Site Folder.

Click OK to build the page.

 

 

To view the new web page you've just created, run your browser and open the file named index.html in the Site
Folder.

Note: You can also preview the page before you build the final files. From the File menu select Preview,
Default Browser. PhotoWebber will build a temporary copy of the page and open it in your default browser.
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Creating a New Document and Adding
Graphics
In addition to importing multi-layered Photoshop files to build complete web pages, PhotoWebber also allows
you to import individual graphics.

You can incorporate existing web graphics - GIF or JPG files - as part of your page layout
or

●   

You can import one or more individual layers from any Photoshop file●   

In this tutorial we will create a new file and add a company logo.

1. Create a new document:

From the File menu, select New
and choose an alignment
option:

For browser versions 4.0
or higher, select Style
Sheet Aligned Web
Page.

●   

For 3.0 or lower
browsers, select Table
Aligned Web Page .

●   

Tip: You can switch between
Style Sheet and Table Alignment
at any time.

2. Import TUTORIAL1.PSD.

Note the blank space in the
upper left-hand corner of the
page. This is where you will
place the logo.

There are two ways you can
import single graphics: from
existing GIF and JPG files, or
by importing individual
Photoshop layers. Both options
are explained in step 3.



3. Add a company logo:

From the File menu, select
Import Graphics.

To import the logo from an
existing GIF:

Select GIF from the list
of available file formats.

●   

Choose LOGO.GIF in
the
PhotoWebberSampleFiles
folder.

●   

Click Open.●   

Drag the logo so it is in the
upper left area of the page.

 

Tip: When importing existing GIF and JPG files, you can use the
existing logo file or create a new one:

To use the existing GIF file on your final web page, click
Link to File on the import window.

●   

To create a new GIF, JPG or PNG file when you build the
page, leave Link to File unchecked.

●   

Notice that the GIF file has only single-color transparency so it
can only be used against the same background color on which it
was created. In this case, the white background does not work.

To import the logo from a Photoshop layer and maintain the full alpha-channel transparency:

Select Photoshop File from the list of available file formats.●   

Choose TUTORIAL1.PSD in the PhotoWebberSampleFiles folder and check Select
Individual Layers For Import...

●   

Click Open.●   



Highlight PW Logo in
the list of layers.

●   

Click OK.●   

Drag the logo so it is in the
upper left area of the page.

 

 

Notice that the full-transparency support allows you to move the
logo so it overlaps several background color areas cleanly.

To see what this will look like on the web, preview the results in your browser. (From the File menu select
Preview, Default Browser.)
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Automating Buttons by Naming Photoshop
Layers
PhotoWebber makes creating JavaScript buttons with rollovers,click states and popups a snap.

Rollover - A rollover graphic replaces the button graphic when the user moves their mouse over the
button in their browser. A button can have only one rollover.

●   

Click State - A click state graphic replaces the button graphic when the user clicks on the button. A
button can have only one click state.

●   

Popup - A popup graphic appears in addition to the button graphic when the user moves their mouse
over the button in their browser. A button can have any number of popups.

●   

If you name your Photoshop layers appropriately and check Auto Button Creation when you import your file
into PhotoWebber, you are done before you even start working.

In this tutorial we will create a button using named Photoshop layers and the preview the resulting
button in PhotoWebber and in a browser.

1. Create a
Photoshop with
button, rollover,
click, and pop-up
layers.

Note: You can use
TutorialButton.PSD
if you do not want to
make your own
Photoshop file.

 

Make sure three
layers overlap and
have the following
names:

button●   

button_r●   

button_c●   

The popup layer can
be anywhere on the
page and should be
named:

button_p●   

Layers with simple names. The simplest way to name layers for automated
buttons is to name your layers in Photoshop. Add _r or _p to the end of the
layer name that matches the button layer name to designate rollover and popup
states. For example:

Main Button Graphic layer name: AnyName●   

Rollover layer name: AnyName_r●   

Click-state layer name: AnyName_c●   

Popup layer name: AnyName_p●   

Note: Other, more complex naming conventions are also supported. See
Graphics in the PhotoWebber User Guide.

http://www.photowebber.com/resources/testnewdocs/PhotoWebberDocs/Graphics.htm


2. Create a new
PhotoWebber
document and
import your
Photoshop file.

For this tutorial, do
not check Auto
Button Creation.

3. Automate the
Buttons.

From the Layers
menu, select
Automate Buttons.

Note that any visible
rollover and popup
graphics disappear
from the Document
window and all are
changed into
sub-layers of the
main button graphic.

Note: If you select a popup layer in the Layers window, a ghosted image of the
layer appears in the Document window.

A popup layer can also have a rollover and click state, and multiple popup
layers can be made into a menu. See Creating Menus for more information.



4. Preview the
button behaviors.

Select the
Interactivity Tool in
the Document
Window.

Point to the button
and click it to see
how it will behave
when you build the
page.

 

To verify how rollovers and popups will behave on the web, build the page and point to each button with your
mouse in the browser.
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Creating Menus by Naming Photoshop
Layers
PhotoWebber makes creating JavaScript menus with multiple buttons a snap.

Menu - A menu is a collection of buttons that pop up in another location of the screen when the user
points to a main button. A pull-down list is a specific type of menu and can easily be created with
PhotoWebber. However, menus can be any shape and can be located anywhere on the screen. Buttons
that are parts of a menu do not need to be touching the main button or the other menu buttons.

●   

If you name your Photoshop layers appropriately and check Auto Button Creation when you import your file
into PhotoWebber, your menus will automatically be programmed with no additional work.

In this tutorial we will create a menu using named Photoshop layers and preview the resulting buttons
created by PhotoWebber.

1. Create a
Photoshop file
with four buttons
with rollovers. (See
Automating Buttons
for more
information.)

Note: You can use
TutorialMenu.PSD
if you do not want
to make your own
Photoshop file.

2. Turn the three
buttons on the
right into a menu.

Add a menu layer
named button_m.

The menu layer
must be below the
buttons that will
comprise the menu
and must overlap
each of the menu
buttons.

The menu layer
should not overlap
the main button
layer.

Tip: If you do not
want a visible menu
boundary in your
web page, set the
_m layer Opacity to
0.



3. Create a new
PhotoWebber
document and
import your
Photoshop file.

For this tutorial,
check Auto Button
Creation.



4. Preview the
button behaviors.

Use the
Interactivity Tool
to preview the menu
in PhotoWebber.

To see how each of the menu items will behave on the web, build the page and point to each button with your
mouse in the browser.

 

Copyright © 2000 - 2001 Media Lab, Inc. All rights reserved.
PhotoWebber is a trademark of Media Lab. Photoshop is a registered trademark and GoLive is a trademark of Adobe Systems Incorporated.
All other trade names are trademarks of their respective owners.

 

http://www.medialab.com/


Switching between Style Sheet and Table
layout
PhotoWebber uses document properties to determine what type of HTML code to generate for each page. To
ensure that the page you build matches your Photoshop layout in your browser, you must select the correct
layout option.

If you are certain that your site visitors will be using browser versions 4.0 or higher, you may want to use Style
Sheets. If your visitors will be using 3.0 or lower browsers, or if you do not know what browsers your site
visitors use, use Tables.

In this tutorial we will build both table and style sheet versions of the same web page.

1. Create a new document.

From the File menu, select
New and choose Style Sheet
Aligned Web Page.

Import TUTORIAL2.PSD

2. Build the style sheet
aligned page.

From the Output menu,
select Set Site Folder... and
choose a Folder on your hard
drive.

Select Output, Build All to
output the HTML and
graphics.



3. Change to Table
Alignment Layout.

In the Properties Window,
select the Layout tab.

Note: If the Properties
Window is not displaying
Document Properties,select
index.html in the Layers
window.

Click Tables (HTML3).

 

4. Set the table Granularity.

PhotoWebber allows you to
control the precision of table
slicing.

Click Options.
For more precision,
enter a lower number.
This results in a table
with more, smaller
cells.

●   

For a simpler table,
enter a higher number.
This results in a table
with fewer larger cells.
Rollover graphics will
have less precise
boundaries.

●   

Select Preview Table to see
the resulting slices in the
Document window.

When you are satisfied with
the results, click OK.



5. Build the table aligned
page.

Set a new Site Folder. Select
a different Site Folder than
where you saved the style
sheet aligned version.

Build the page and graphics.

To see how style sheet and table layouts differ, open each page in your browser and view the HTML source.
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Creating Frames and Setting Colors
Because PhotoWebber was designed to build web pages from complete designs created in Photoshop,
working with frames is much more intuitive than in standard HTML-based applications.

In standard web-design applications, frame design can be quite complex. First you have to decide
where your frames will be, and what size they will be. Then you must create separate HTML pages
for each frame. Finally, you assign a specific web page to be "inside" each frame.

PhotoWebber introduces drag-and-drop frames. Simply create your page design in Photoshop,
import the file into PhotoWebber, and insert the frames. That's it. PhotoWebber takes care of the
technicalities. And, if you change your mind, it's not a problem. Any element can be moved to any
frame at any time. Most elements can even cross frame boundaries. This provides the flexibility to
change your mind without having to rebuild separate HTML files for each frame just to move a single
item.

In this tutorial we will create a page with frames.

1. Create a new document and
import TUTORIAL2.PSD.

 

2. Create a frameset.

Web pages with frames contain
several HTML files: one for the
content of each frame and one
that ties all of the frames
together. This is known as a
frameset.

From the Insert menu, select
Horizontal Frameset Divider.

The frameset divider line will
appear in the middle of the
document window. Drag the
gray line up so it is just below
the black bar.

A folder and layers tab will be
created for the contents of each
frame.



3. Change the background
color of the top frame to green
and delete the green Color
Area.

When a Photoshop file contains
a solid color layer named
"Background", PhotoWebber
disables this layer and uses its
color for the page background.

When frames are created, they
maintain the background color
of the original page. In this
example, we want the
background of the the top frame
to be a different color.

First, select Frame 1 by
clicking in an empty area
of the frame background.

●   

Then click the
eyedropper on the
Background tab of the
Properties window and
click within the green
Color Area.

●   

Finally, select the green
Color area and delete it.

●   

4. Resize the purple Color
Area in Frame 2.

PhotoWebber automatically
converts all layers containing
rectangular areas of a single
color into Color Areas.

Move the purple color area so it
is centered behind the
PhotoWebber logo graphic. Drag
the resize handle to enlarge the
color area past the bottom of the
graphic and text.

To see how this page differs from the non-frames version created in the Instant Web Page Tutorial, build the
page view it in your browser.
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Photoshop Text Layers
Photoshop 5 allows you to edit text and make changes to individual characters and words within a text
block. This is because Photoshop text layers now include both the actual text you typed in and the graphic
representation of that text, including the attributes you assign such as font, size, anti-aliasing, and color.
PhotoWebber recognizes Photoshop 5 text layers and includes both the graphical representation of the text
as well as the real text.

When you import a Photoshop text layer into PhotoWebber, it is initially set as a graphic layer and is
treated in the same way as any other graphic layer. When you build your page, the graphical text will be
output as a GIF, JPG or PNG file as you define it in the graphics properties window.

You can change also any Photoshop text layer to real text.

In this tutorial we will convert a graphic text layer into type.

1. Import
TUTORIAL1.PSD

 

2. Convert the center
bottom text area to type.

Select the layer named
"PhotoWebber
automatically gener".

From the Layers menu,
select Set Type and then
Text,
or
Click the small arrow on the
Text icon in the Layers list
and select the simple T icon.



Note: When using Tables for
alignment, text layers are
always the topmost layers on
the page. The background
color of text layers will
match the background of the
area on the page where the
top left corner of the text
block is placed. The text
block will obscure any
graphics behind it.

3. Add a hyperlink to the
word "PhotoWebber".

Double-click on the text
layer in the Document
window.

Highlight the word
PhotoWebber.

In the Hyperlink box, type
http://www.photowebber.com
and select This Frame (no
target) as the Target Frame.

Click OK.

Build the page and view it in your browser. Notice that the text layer has not been output as a graphic but,
rather, the text has been incorporated into the HTML page with a link to the PhotoWebber Web site.
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Setting Absolute and Relative Position and
Size
PhotoWebber supports Frame and DHTML sizing and positioning options.

In this tutorial we will fine-tune a page layout using page, frame and graphics properties for defining
position and size.

1. Create a new document with Style Sheet Alignment and import TUTORIAL7.PSD.

2. Create a frameset and set
the background colors.

From the Insert menu, select
Vertical Frameset Divider.

Position the divider so it is just
to the left of the gold panel.

Set the background color for
each frame and delete the
temporary background layer.

3. Set the frame size options.

With Frame 1 selected, click the
Layout tab on the Properties
window.

Assign the following
settings:
Align with Style Sheets
X-Size Undefined

●   

Select Frame 2.
Assign these settings:
Align with Style Sheets
X-Size Absolute

●   

With these settings, the
right-hand frame with the HTML
buttons will stay a constant size
and the left-hand frame will
resize to fill the browser
window.

 



4. Set the graphics layout
options.

Select the black bar layer in
Frame 1.

On the Layout tab in the
Properties window, assign the
following settings:

Position
X Pos Percentage
Y Pos Pixels

●   

Size
X Percentage
Y Pixels

●   

With these settings the black bar
will resize to the full width of
Frame 1 as the browser window
is resized.

Select the H, T, M and L layers
in Frame 2 and assign these
settings:

Position
X Pos Pixels
Y Pos Percentage

●   

Size
X Pixels
Y Percentage

●   

With these settings, the buttons
in Frame 2 will spread out to fill
the height of the frame as the
browser is resized.

Note: The interactive warnings
window will warn you of
incompatibilities with specific
browser versions.

 

Preview the page in both Netscape and Internet Explorer, changing the size of your browser window several
times to see how the elements on the page are rearranged and which features are supported in each browser.
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Optimizing Graphics and Organizing Files
PhotoWebber's Output View provides a variety of file management tools including: defining a Site Folder,
creating new folders, moving graphics and HTML files to different folders within the root, renaming pages,
files and folders, and resolving file conflicts. (For more detailed information on Managing Files and Folders,
see PhotoWebber User Guide, HTML.)

PhotoWebber also provides options for defining output graphics file formats and optimization.

In this tutorial we will change file formats, define optimization settings and create a new folder for our
graphics files.

1. Create a new document
and import Tutorial5.PSD.

2. Set GIF optimization.

Select the Button layer.

In the Graphics Properties
window, change the Number
of Colors to 16.

Tip: To reduce the size of
each GIF file, PhotoWebber
automatically reduces the
number of colors in the
palette to the actual number
of colors used. You can force
PhotoWebber to write GIFs
with fewer colors by
specifying the maximum
number of colors to use.

3. Set JPG optimization.

Select the PhotoWebber
layer.

In the Graphics Properties
window, change the File
Type to JPEG.

Change the Quality to 50.

 

http://www.photowebber.com/resources/testnewdocs/PhotoWebberDocs/HTML.htm


Note: The Properties window
and the icons in the Output
View list change color to
reflect the new file types.

3. Select a Site Folder and
Create an IMAGES folder.

From the Manage menu in
the Layers window, select Set
Site Folder and choose an
empty folder on your hard
drive.

Then select New Folder from
the Manage menu.

Highlight the new folder in
the Output View list and in
the Properties window,
change the name of the folder
to Images.

4. Move all of the graphics
into the images folder.

Drag the graphics icons and
drop them onto the Images
folder.

 

 

Build the page and examine the files that are output on your hard drive. Compare this to the list shown on the
Output View tab.
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Setting Hyperlinks
PhotoWebber allows you to add a hyperlink to any graphic layer on the page. You can also add hyperlinks to
real text. If you have frames, you can also select the destination frame for each hyperlink:

Current●   

Parent●   

New Window●   

Any Existing Frame●   

In this tutorial we will add hyperlinks to a graphic and to text.

1. Import
TUTORIAL1.PSD

 

2. Add a hyperlink to a
graphic.

Select the layer named
PhotoWebber Logo.

In the Properties window,
select the IMG tab and type
http://www.photowebber.com
into the Hyperlink box.

Note: You can also click the
browse button to select any
HTML file in your Site
Folder.

3. Add text with a
hyperlink.

Select Insert, Text and type
Welcome to Media Lab in the
Text Entry box.

Highlight the words Media
Lab then type
http://www.medialab.com in
the Hyperlink box.

Click OK.

The text block appears in the
upper-left corner of the page.
Drag the text to a blank area
of the page.



To see what this will look like on the web, preview the results in your browser. (From the File menu select
Preview, Default Browser.)
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Using HTML Extensions to Plug-in Media
Files
You may incorporate Flash, Shockwave, Quicktime and Java Applets using HTML Extensions .

In this tutorial we will create a Placeholder and insert an HTML file.

1. Create a new PhotoWebber
document and set the Site
Folder.

 

 

2. Insert an HTML Extension.

From the Insert menu, select
HTML Extension.

Choose Flash, Shockwave,
Quicktime or Java Applet.

An HTML Extension placeholder
layer is added to your page.

3. Insert the media file.

On the Properties window, select
the Extension tab.

Click the document insert
button and select a media file in
your Site Folder.

Note: For Quicktime Extensions,
check autoplay, display
controller and loop if desired.



To see what this will look like on the web, preview the results in your browser. (From the File menu select
Preview, Default Browser.)
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Using Placeholders for Existing HTML
Content
You may incorporate existing site content into any PhotoWebber projects by using Placeholders and Frame
Placeholders.

A Placeholder is a rectangular area that contains HTML code. Any layer in PhotoWebber may be designated
as a placeholder. You can type HTML code directly into the Source HTML window, select any HTML file
from your hard drive, or choose from a list of HTML files within the designated Site Folder. In style sheet
layout, each placeholder is a separate HTML layer and supports standard style sheet overflow settings. In table
layout, each placeholder is a table cell. HTML incorporated using a placeholder becomes part of the web page
built by PhotoWebber.

Frames may also be designated as placeholders. A Frame Placeholder is a frame that contains HTML code
created in a separate PhotoWebber session or by any other HTML editor. HTML incorporated using a frame
placeholder is referenced by the frame set built by PhotoWebber, but is not incorporated into a page built by
PhotoWebber.

In this tutorial we will create a Placeholder and insert an HTML file.

1. Import TUTORIAL2.PSD.

For this tutorial, do not select
Automate Buttons.

 

2. Delete the PhotoWebber Logo
and the text layer below it.

 

3. Create the Placeholder.

Select the purple Color Area.

From the Layers menu, select Use
as Placeholder.

The color area will turn gray,
indicating that it is now a
Placeholder.



3. Insert the HTML file.

On the Properties window, select
the Placeholder tab.

Set the Overflow for the
Placeholder to visible.

Note: The interactive warnings
window will warn you of
incompatibilities with specific
browser versions.

Click the document insert button
and select PWINFO.HTM. The
HTML code will display in the
Source HTML box.

Note: you can also type or paste
HTML directly into the Source
HTML box.

To see what this will look like on the web, preview the results in your browser. (From the File menu select
Preview, Default Browser.)
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